[CentOS] centos 4 installed on P4 won't boot on P3

Tom admin at homemachine.net
Thu Sep 29 12:25:14 UTC 2005

Karanbir Singh wrote:
> Tom wrote:
>>>> The DC guys tried grub-install in rescue mode but still the same.
>>> did they check the drive lables ?
> is there another drive in the machine that has the same parition label?

no, thats the only drive in the machine at present.

>>> is /boot/grub/grub.conf configured to point at reality ? or is it 
>>> looking at non-existant stuff ...
>> not quite sure what you mean on both those questions, grub.conf and 
>> fstab are correct, it was a standard install which worked fine on the 
>> P4 but not at all on the P3.
> moving the drive from /dev/sda to /dev/sdb can also cause the bootloader 
> to not find the kernel / initrd and bomb out at that stage. so make sure 
> the bootloader is installed on the right place, and knows where to find 
> the /boot information.

do you mean on the wrong hdd terminator? will check that out.

> - K

More information about the CentOS mailing list