[CentOS] SSH + VNC

Sat Apr 1 12:59:01 UTC 2006
Ryan <ryanag at zoominternet.net>

I am trying to log into a desktop that is running CentOS 4.2 by
tennelling VNC through SSH..

The desktop auto-logins a user, then sits there waiting for me to login.

On the client side, I fire up SSH tunneling
ssh -L 8000:

The client spits back the error
vncviewer: ConnectToTcpAddr: connect: Connection refused
Unable to connect to VNC server

The server says
channel 5: open failed: connect failed: Connection refused
channel 5: open failed: connect failed: Connection refused

I've tried
ssh -L 5900:
ssh -L 8000:localhost:5900

and neither work.

I've also tried using the command vino-preferences on the remote
desktop. It tells me to connect to vnc:/IP-address:0

Whats interesting is that if I issue the command
on the remote desktop, it starts up a new server on display :1. I can
connect to this display with no issues via the SSH tunnel.

Does anyone know how I can fix this problem? I use SSH tunneling and VNC
with display :0 on SUSE 10.0 machines all the time without issues.