[CentOS] large disk volumes with 64bit kernel

Tue Dec 12 22:43:31 UTC 2006
Daniel Senie <dts at senie.com>

At 12:52 AM 12/12/2006, Feizhou wrote:

>># fsck /dev/sdb1
>>fsck 1.35 (28-Feb-2004)
>>e2fsck 1.35 (28-Feb-2004)
>>The filesystem size (according to the superblock) is 549346683 blocks
>>The physical size of the device is 12475771 blocks
>>Either the superblock or the partition table is likely to be corrupt!
>>Abort<y>? yes
>>Is there some way to build single volumes larger than 2TB? It 
>>should not be a problem with a 64 bit OS (Windows managed to do it 
>>on this hardware before I switched it over to Linux). Is there some 
>>tuning I need? Any pointers to documents or other useful references 
>>would be appreciated. Thanks for any/all help.
>Are you using a GPT partition for that 2.x TB filesystem?

I wasn't. I had let the installer set up the partition using LVM. 
Then I tried without LVM. No matter what I did, it went boom.

I used parted to create a gpt partition, and was able to build a 
clean file system that fsck doesn't get upset about.


Thanks VERY much for this info. It solved my problem.

Both anaconda and the LVM GUI created partitions that were unusable. 
Nice set of bugs.