[CentOS] large disk volumes with 64bit kernel

Wed Dec 13 19:29:36 UTC 2006
Kevan Benson <kbenson at a-1networks.com>

On Tuesday 12 December 2006 14:43, Daniel Senie wrote:
> >Are you using a GPT partition for that 2.x TB filesystem?
> I wasn't. I had let the installer set up the partition using LVM.
> Then I tried without LVM. No matter what I did, it went boom.
> I used parted to create a gpt partition, and was able to build a
> clean file system that fsck doesn't get upset about.
> >http://www.wlug.org.nz/GPT
> Thanks VERY much for this info. It solved my problem.
> Both anaconda and the LVM GUI created partitions that were unusable.
> Nice set of bugs.

This wasn't on the bootable drive I take it, or you wouldn't be able to boot 
after switching to the GPT partition table (and you would probably find it 
hard to switch to GPT while preserving the data anyway).  If you don't really 
need multiple partitions on the device, you can also do away with any 
partitioning scheme and just create an LVM instance on the device itself.

There's a bit more info about this in the thread "Large disk support" started 
by me on 2006-11-28, as went through some related problems.

- Kevan Benson
- A-1 Networks