[CentOS] Re: How to connect to a Windows PC in LAN

Mon Dec 18 14:09:23 UTC 2006
MikeW <mw_phil at yahoo.co.uk>

Ha Thai Duong <duongthaiha at ...> writes:

> Hi
> I am a new bee to Linux in general. Please accept my apologies if the 
> question is not appropriate.
> I have a LAN with 2 computers: One is CentOS and one is Windows XP.
> I am trying to transfer file between 2 computers using LAN. Can you 
> please tell me how to do it?
> I have tried Samba from the Applications menu.
> Add a directory in there. Set it to Read only and Allow access to 
> everyone. I couldn't see the CentOS from Windows computer.
> I have tried the Network Servers. There is Windows Network there. When i 
> click to see inside that, there is nothing.
> I tried to see the all the services are running. The winbind status is
> winbindd dead but subsys locked.
> Thanks a lot for your help. I do appreciate that.

Simplest way - share directory (e.g.)"shared" on Windows PC,
then NFS mount it under Linux.

On Windows: select folder "shared", set permissions for your username
as 'full control',
Create sample textfile xyz.txt in the directory to check visibility.
Note the machine name of the Windows box (my computer: properties).
The machine name can only be used on some networks, but the IP
address should always work.

Find the IP address of the Windows machine;
in a console window type 'ipconfig', note the IP address (e.g.
[If you have more than one network interface, it should be that connected to
the Linux system!]

On the Linux box, as root,
1. create a mountpoint for the Windows directory, e.g. /mnt/shared,
make it owned by yourself, group 'users' (chown ... chgrp as root)
2. create a credentials file /home/yourname/.cred for your Windows login,
containing text (fill in correct text!)

3. add the following line (it's all one line) to the end of
the text file /etc/fstab (you'll need to be root):
//<Windows IP address>/shared /mnt/shared smb

(Your system may allow you to use the machine name instead of the IP)

4. as root, type:  mount /mnt/shared, you should then be able to see the
file xyz.txt. Using "-v" option to mount might give more info about reason
if this is unsuccessful.