[CentOS] Proftpd hangs

Fri Dec 22 21:54:09 UTC 2006
Kevan Benson <kbenson at a-1networks.com>

On Friday 22 December 2006 06:38, Ferdinando Santacroce wrote:
> Well, I use proftpd.i386 -|- 1.3.0-5.1.el4.kb in
> standalone mode, from kbsingh repo. I tried to disable
> all <VirtualHost> directives, and proftpd starts well,
> and FTP places are correctly browsable (from local
> 192.168.x.x IP address).
> Well, now it works, but I can't understand why it stop
> to run...
> In last reboot I had 3 virtual hosts; I added in this
> week 3 other virtual hosts, by a simple cut&paste and
> a normal conf change, and I restarted the service, and
> it worked well.
> Today, after the reboot, the misterious hang...
> I have no time now to search in logs a possibly
> solution, my boss can't understand these things...
> I'll find time later.

From what I remember, proftpd is very picky about host names and DNS unless 
you tell it not to be in the config.  There is usually something in the logs 
to the effect of "Error: could not determine IP address of your.host.name" 
from proftpd.

In any case, as most the responses have suggested, /var/log/messages will most 
likely have the cause of the failure.

- Kevan Benson
- A-1 Networks