[CentOS] How to connect to a Windows PC in LAN

Fri Dec 22 07:12:32 UTC 2006
Wei-min Lee <weiminlee at sbcglobal.net>

Samba has worked great for me.  I'm no expert myself, but this is how it
works for me...

   workgroup = WORKGROUP  <--Default windows workgroup name
   netbios name = <hostname>
   hosts allow = 192.168.1.  <--Allows access from my subnet
   security = user
   encrypt passwords = yes
   smb passwd file = /etc/samba/smbpasswd

        comment = Install programs
        path = /installs
        valid users = joeschmoe
        read only = No
        writeable = Yes
        write list = @joeschmoe
        create mask = 0775
        directory mask = 0775

Since my private LAN is already firewalled, my centos server has firewall

To simplify the connection to Samba, joeschmoe is my windows account and the
passwords are identical between XP and centos.

# smbpasswd joeschmoe to sync the passwords

Also, check /var/log/samba for errors

Wei-min Lee

-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf
Of MrKiwi
Sent: Sunday, December 17, 2006 2:45 PM
To: CentOS mailing list
Subject: Re: [CentOS] How to connect to a Windows PC in LAN

Ha Thai Duong wrote:
> Hi
> I am a new bee to Linux in general. Please accept my apologies if the 
> question is not appropriate.
> I have a LAN with 2 computers: One is CentOS and one is Windows XP.
> I am trying to transfer file between 2 computers using LAN. Can you 
> please tell me how to do it?
> I have tried Samba from the Applications menu.
> Add a directory in there. Set it to Read only and Allow access to 
> everyone. I couldn't see the CentOS from Windows computer.
> I have tried the Network Servers. There is Windows Network there. When i 
> click to see inside that, there is nothing.
> I tried to see the all the services are running. The winbind status is
> winbindd dead but subsys locked.
> Thanks a lot for your help. I do appreciate that.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
"service smb status" will tell you if the services (smbd, 
nmbd) are running but ...

Maybe your firewall is active and blocking your requests;

 From a root prompt type
# service iptables status

If the response is "Firewall is stopped" then this is not 
the problem - however if you get a list of the firewall 
entries, then try
# service iptables status|egrep "445|137|138|139"
You should see 4 or so entries listed for the various 
services related to samba sharing.

If you see none, you need to either ;
stop the firewall (not recommended, but you may want to stop 
it to confirm that the firewall is the issue) using
# service iptables stop
(restart it with # service iptables start)
config the firewall to allow these ports (recommended solution)

try /usr/sbin/s

set Security Level to "Enabled",
Customize, under "Other ports" type "445:tcp 137:udp 138:udp 

This should allow all the samba services to ba accessed.



CentOS mailing list
CentOS at centos.org