[CentOS] SATA RAID Controller Support?

Tue Feb 14 19:26:44 UTC 2006
Aleksandar Milivojevic <alex at milivojevic.org>

Quoting Ryan Pitt <ryan at marinocrane.com>:

> I tried these drivers and nothing worked.
> I have just tried Fedora Core 5 Test 2 release and it finds the card 
> right away just by booting to disk 1. Perhaps the next version of 
> CentOS will support these cards by default.

Then it was most likely PCI ID not matching anything in linit.c file.

If you want to play with it, you may try one of these two things.

Go to www.adaptec.com and go to "product downloads" for any 2x10SA card 
(they all use same device driver, aacraid).  Download Linux 
Installation Driver Diskette for RHEL4.  You can also try with Dell's 
support site (sometimes they are suprisingly usefull, sometimes not).  
Try feeding it to CentOS installation program during install.  Might 
work.  Note that you might need to recompile Adaptec's driver every 
time you want to update the kernel.  Once your card is supported in 
RHEL4, you may roll over to stock RHEL4 driver.

Failing that, you might try it the good old hard way.  Install to some 
other disk (for example standard IDE disk), then recompile the kernel 
with linit.c file patched to include PCI ID of your device.  You might 
check for differences between the linit.c file in current Fedora or 
linux.org kernel and the 2.6.9-22.EL included with RHEL4/CentOS4.  You 
can also use "lspci" and/or "lspci -n" to find out what is PCI ID of 
your card.  Don't just copy the file, only add the device ID you need 
(probably two lines to add to the file).  Once you can see the array, 
migrate the system to array.  Lots of work, but it might work.  You'll 
end up with custom kernel, so you'll need recompile every time there's 
kernel update (until Red Hat includes your card's PCI ID into RHEL 
kernel).  The fastest way to get your card supported in RHEL4 would be 
to send patch for linit.c to Red Hat.

This message was sent using IMP, the Internet Messaging Program.