[CentOS] Kickstart from floppy falling into regular install

Fri Jul 28 15:33:06 UTC 2006
Robert Moskowitz <rgm at htt-consult.com>

I took my anaconda-ks.cfg file, cp to ks.cfg and copied to a floppy

The isos have been copied to an ftp server.  So I had the following 
lines in my ks.cfg

url    (yes the ftp server's directory is the Centos 

This is along with all the appropriate network command to get the 
ethernet setup.

I issue the linux ks=floppy (also tried linux ks=hd:fd0:/ks.cfg).

What happens is I see the diskette drive spin.  The FTP server shows 5 
connections pulling 0 bytes each then one of 4197 bytes (the size of the 
release-notes-EN.html file).  At this point I get a monitor and mouse 
probe then Anaconda starts up X and goes into the standard install 
choices, starting with how do you want to partition your drive.  
Obviously it is ignoring my partition instructions in the ks.cfg file.  
Also I HAVE monitor and keyboard info in my ks.cfg, it should have used 

Appearantly, I need something added to the anaconda-ks.cfg file, but 
reviewing my notes from when I did thus successfully back in March, I 
can't remember it.  I also tried placing the ks.cfg on the ftp server.  
But that is 2k in size, so it was never ftped.

I see the reference to the text option for kickstart, but that does NOT 
seem to be what is needed here.

Also I seem to recall something about options for the install line in 
ks.cfg, but have not found anything on that.

I continue to research, but any help would be greatly appreciated.