[CentOS] LVM Snapshots -broken ? Ever worked ?

Johnny Hughes mailing-lists at hughesjr.com
Thu Mar 16 12:06:05 UTC 2006

On Thu, 2006-03-16 at 21:33 +1000, Bards1888 wrote:
> I've upgraded my x86_64 4.2 box to the latest kernel and tried
> an lvm snapshot. It worked fine and I was able to mount the snapshot
> etc. Now I cannot seem to remove the snapshot.   If I try a 'lvremove'
> it asks if I want to remove the 'active' snapshot, if I say yes it just
> hangs and the box goes to 99% wait io, however the disk lights do not
> come on during this. The lvremove process is not straceable so I've got
> no idea whats going on with it.
> Luckily I  chose to snapshot /tmp so it is not a show stopper. What I
> did to get around it was to comment out my tmp lv from fstab and just
> allow /tmp to be part of the root filesystem on the root lv.  I
> deliberately filled up the snapshot so that it was marked inactive but
> it still thinks it is active when I run the lvremove command again. I
> also tried to lvremove the tmp lv, not the snapshot, and it  said it
> couldnt remove the lv while there was a snapshot.
> I found a thread on the forums where Karanbir Singh states that this
> sort of thing was broken in early 4 series but may work in 4.3.
> Does anyone know how I can clean this up ?
> Cheers,
> Bards.

Hold off just a little bit and the entire 4.3 distro will come out with
some new lvm tools (a couple days).  That might clear up your issue.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.centos.org/pipermail/centos/attachments/20060316/977730d4/attachment.bin

More information about the CentOS mailing list