[CentOS] Centos 4 on Tyan S2895 with sata

Gavin Carr gavin at openfusion.com.au
Fri Mar 31 04:02:45 UTC 2006

Hi Zube,

On Thu, Mar 30, 2006 at 07:08:53PM -0700, Zube wrote:
> On Fri Mar 31 09:39:24 AM, Gavin Carr wrote:
> > Just wondering if anyone out there has got Centos 4 installed on a Tyan
> > S2895 (that's a Thunder K8WE) motherboard on sata disks? I know about 
> > the forcedeth bug, but I'm getting installation hangs at random spots in
> > the install, even off CD, in what seem to be nv_sata timeout problems. 
> I started down the painful x86_64 road late last year with CentOS 4.2.
> There is a message in the archives where I mistakenly attribute many of the
> problems I experienced to a Logitech mouse.  Thanks for the opportunity to
> set things straight.
> For the record, I tried:
> disabling the SATA RAID, even though I had only one disk
> disabling the onboard SATA and using 2 different brands of PCI 
>   SATA controllers
> pulling my hair out
> all to no avail.  The main symptom was a hard hang and errors of this form:
> ata4 command 0x25 timeout, stat 0x50 host_stat 0x24
> ata4 command 0x35 timeout, stat 0x50 host_stat 0x24

Yep, that's what I'm seeing too, with the odd ata3 timeout mixed in. Great
to have the problem confirmed - thanks.

> Sometimes the machine would recover after a long wait, other times nothing
> but a power cycle would fix it.  This was with the 1.01 and 1.02 Tyan bioses.
> Installing a SCSI card and an old SCSI disk in the machine made it happier, 
> but slower.
> As a last resort before installing a different distribution, I downloaded
> the kernel source and using the .config file as a base, I added
> everything I could find related to SATA and SCSI.  I had to compile it on
> an nfs-mounted drive, for fear of tickling the host_stat error.  The new
> home-spun kernel has been a success; I haven't seen the errors since.  I
> then installed the 2.6.16 kernel compiled locally and still no errors.
> The machine hasn't been tested thoroughly, but it is most certainly usable
> with a newer kernel.

Which matches my experience of SuSE10 working fine on the same MB, with a
(SuSE-patched) 2.6.13 kernel.

Thanks much,

More information about the CentOS mailing list