[CentOS] Anaconda allows x86_64 CD/DVD to be used to install i386 system

Aleksandar Milivojevic alex at milivojevic.org
Thu May 4 14:03:25 UTC 2006

Quoting Karanbir Singh <mail-lists at karan.org>:

> Aleksandar Milivojevic wrote:
>> Let say the tree on my install server looks like this:
>> /centos/os/i386
>> /centos/os/x86_64
>> If I use x86_64 media to boot, but by mistake in ks.cfg file I had
>> something like:
>> url http://installsrv/centos/os/i386
>> Anaconda will happily install from i386 tree.
> no it wont. try it, really.

Actully, it works.  Try it.  Really.  I just did it.  And did it once  
again just to make sure it really works.  It works.  Anaconda is not  
complaining.  It should.  But it doesn't.

> at buildtime a timestamp and a session stamp are inserted into both ends
> of the side for a network install. unless they match - you cant install
> anything. you cant even use a boot.iso from a different build cycle
> against a different tree, even in the same arch...

You mean the first line of .discinfo?  Seems to be ignored.  At least  
with 4.3 media.  I built my DVD from CD images using mkdvdiso.sh script.

> so, umm.. how did you achieve this :)

As I said.  I had "url --url http://installsrv/centos/os/i386/" in my  
ks.cfg.  I forgot to replace i386 with x86_64.  I booted off x86_64  
DVD intending to install x86_64.  And it "worked".  It shouldn't have  
worked.  But it did.  Try it.  It installed from i386 tree.  As if I  
booted from i386 DVD.

After installation it all booted fine, as if I did i386 install.  But  
somehow yum believes this is x86_64 installation ($basearch expands to  
x86_64 in yum config files).  Bad things happen when  
installing/updating via yum (can't run 64-bit binaries under 32-bit  
kernel).  Plus, yum is *installing* (as in "rpm -i") x86_64 packages  
when I do "yum update".  Creating a total mess in the system.

See Ya' later, alligator!

More information about the CentOS mailing list