[CentOS] LiveCD different sums but file size match

Alain Reguera alain.reguera at gmail.com
Sun May 21 01:03:41 UTC 2006

On 5/20/06, Maciej Żenczykowski <maze at cela.pl> wrote:
> This just means that your download most likely got very slightly corrupted
> somewhere during download - it might be a single lit bit which flipped, or
> it might be major.

Ahh, the connection is treating me bad, I've been trying like 3 times
with a crontab-wget line. Think, there most be another waiting crontab
night :-).

> The best solution would be to resume the download via bittorrent or via
> rsync to redownload only the part (most likely way < 1%) which differs.
> If you can't use the above (not sure if there is a torrent for it...)

I have no access to bittorrent here :-\ .

> then
> you'll have to delete and redownload -- or burn anyway and hope for the
> best :)

well, think this will be my another crontab-wget waiting night ;-)

> As for rsync - I'd suggest finding an rsync capable server
> (mirror2.kernel.org comes to mind, not sure if it carries the liveCD) and
> trying rsyncing from it... (read up on man rsync, although it's not
> light reading).
> As a starting point the following will likely work (one line) - remember
> to include the proper path to the destination file (last parameter) or to
> have it in the current dir:
>    rsync -vv --stats -rlptDHSzP --delete
>    "rsync://mirrors2.kernel.org/centos/4.3/isos/i386/CentOS-4.3-i386-LiveCD.iso"
>    "CentOS-4.3-LiveCD.iso"
> (not all the options are needed but I'm riping of my own script which does
> site wide mirroring)

Thanks Maciej, appreciate a lot that clean suggestions. I heavily
tried to do an rsync, some time ago, to mirror a repository and keep
some local updated packages here for the local servers and some
workstations but just errors appeared to me when I tried to do so, all
seem to me like have no read enough about it or that a top level
firewall (which I've no control of) in the intranet is blockin it. I
am studying firewalls now to have more arguments about this issue and
be able to use the wonderful-necessary rsync tool, that I think should
study a little more.

By now, I will delete and redownload the entire file using my friendly
wget again (hoping the best) and will write you back the results.

> Cheers,
> MaZe.


More information about the CentOS mailing list