[CentOS] problem with ldap, sendmail, dovecot

Myron Williams list at wcstc.com
Mon May 22 19:29:14 UTC 2006


Hi all,

I have recently started to use CentOS. I have setup a mail server running
centos 4.3 with dovecot, sendmail, and spamassassin.  The user information
is located in a openlapd database on a separate machine.

I am currently seeing connection from the mail server to the ldap server
left open which causes some interesting behavior.  Sendmail will
occasionally return email messages as user unknown when the user exists. 
This behavior will steadily get worse until the number of connections fill
up.  When ldap is restarted the process starts over again.  If ldap is
restarted every hour the behavior stated above is not seen.  Email is
delivered as would be expected.

Doing tcpdump shows connections from dovecot and sendmail that have are in
an open state.  I find the connections that were is the open state finish
their request and close.  Occasionally I see connections that were doing
dovecot authentication before the reset will change and do a sendmail
request then close.

When a load was first put to the mail server dovecot authentication would
just start (authenticate < 10 people) and lockup.  Upon googling I found a
article that said to set dovecot to use ldap directly instead of using pam
(create the dovecot-ldap.conf file).  This I did and the authentication
problem appeared to have gone away.

I have tried to find information to help solve this problem of the open
connection but without success.

If someone could point me in the right direction to solve this problem it
would be appreciated.

Myron Williams




More information about the CentOS mailing list