[CentOS] NTP

Sam Drinkard sam at wa4phy.net
Wed May 24 16:45:47 UTC 2006

Will McDonald wrote:

> On 24/05/06, Sam Drinkard <sam at wa4phy.net> wrote:
>>    Have there been any changes to the way ntpd behaves in the past few
>> updates?  Reason I ask, whenever I run the ntpq or ntpdc, I immediately
>> get a response of Name or service not known.  I know things used to work
>> sometime back, and never saw this kind of stuff.  Nothing has changed in
>> the /etc/ntp.conf file, nor has anything changed in the
>> /etc/ntp/ntpservers files.
> According to the changelog of the NTP package nothing's changed since 
> '04!
> $ rpm -q --changelog ntp | less
> "Name or service not known" sounds more like a resolution issue to me.
> Do you by any chance have caching-nameserver installed and had
> modified /etc/named.conf ? If so a caching-nameserver update may've
> overwritten your previous modifcations and potentially have broken
> DNS.
> Are you using N.pool.ntp.org in /etc/ntp.conf? Can you resolve those 
> hostnames?
> $ awk '/ntp.org/ { print $NF }' /etc/ntp.conf | xargs -n1 dig +noall 
> +answer
> Will.


    Everything has worked correctly in the past, and I have not made any 
changes to the config files, nor dns, which is not a caching server.  A 
little bit more info.. somehow, the machine on which I'm having this 
issue is i386, where the machine here at home is x86-64.  It works as 
advertized.  I copied all the config files over and deleted the first 
entry from the hosts, which on the local machine pointed to the remote 
machine.  Other than that, they both are identical now.  If, when 
executing either command, I enter "host vortex.wa4phy.net" then I get 
normal behavior.  Somehow, it is not setting the default host, or a 
default host.  I'm totally at a loss to explain unless there are some 
diffs between the two arch's.



More information about the CentOS mailing list