[CentOS] NTP

Sam Drinkard sam at wa4phy.net
Wed May 24 17:26:47 UTC 2006

Robert wrote:

> Sam Drinkard wrote:
> <snip>
>> Will,
>>    Everything has worked correctly in the past, and I have not made 
>> any changes to the config files, nor dns, which is not a caching 
>> server.  A little bit more info.. somehow, the machine on which I'm 
>> having this issue is i386, where the machine here at home is x86-64.  
>> It works as advertized.  I copied all the config files over and 
>> deleted the first entry from the hosts, which on the local machine 
>> pointed to the remote machine.  Other than that, they both are 
>> identical now.  If, when executing either command, I enter "host 
>> vortex.wa4phy.net" then I get normal behavior.  Somehow, it is not 
>> setting the default host, or a default host.  I'm totally at a loss 
>> to explain unless there are some diffs between the two arch's.
>> Sam
> Sam, just for grins, why don't you try replacing host names with IP 
> addresses in your /etc/ntp.conf  (after copying the original somewhere 
> safe!), issue a
> #service ntpd restart
> and see what that does.  Another thought:  If you have a single-core 
> processor accidentally running an smp kernel, ntpd will never 
> stabilize.  At least, that's the way it works on this AMD Athlon I'm 
> using right now.

    I reverted back to the original configuration, and in the process, 
looked at the system-config-services.  I'm seeing with the ntpd service 
stopped, but the subsys is locked.  There was a pid file, but removed 
it.  I can try ip's but they recommend using hostnames for most places 
due to the fact that IP's might change (a lot of the gov't servers are 
like that).  I'm still dorking around trying to find what is exactly 
locked -- what subsys ?  Anyhow, the machine does not run the smp 
kernel, but the machine here IS smp and runs the smp kernel.  I'm just 
baffled why with identical config files, I still get the service not 
known message.  Weird......


More information about the CentOS mailing list