[CentOS] Trouble syncing Palm via USB

Tue Oct 17 17:00:14 UTC 2006
Marc D. Field <lists at fieldinternet.com>


I'm having trouble getting my Palm to sync with jpilot on my Centos 
system via USB.  When I sync, I get this error in jpilot:

pi_accept Illegal seek
Exiting with status SYNC_ERROR_PI_ACCEPT

I have jpilot syncing fine with this Palm over the network, BTW.  For 
USB, I set things up for udev as described on various websites.  Here 
are the relevant ports & symlink (created and deleted automatically with 
each sync attempt):

lrwxrwxrwx  1 root root 7 Oct 17 09:09 /dev/pilot -> ttyUSB1
crw-rw----  1 root uucp 188, 0 Oct 17 09:09 /dev/ttyUSB0
crw-------  1 marc uucp 188, 1 Oct 17 09:09 /dev/ttyUSB1

I added myself to the uucp group.  It doesn't look like this is a 
permissions issue, does it?  (I saw a message in the list's archives 
indicating that one must start jpilot as root in order to sync, but this 
doesn't make sense to me.)

Any ideas as to what's going wrong?  Are others syncing Palm devices to 
their Centos boxes via USB (and from normal user accounts)?

I have tried other things, such as using a different USB port on the PC, 
and having jpilot sync to /dev/ttyUSB0 and /dev/ttyUSB1 instead of the 
/dev/pilot symlink.  I've also searched the jpilot mailing list 
archives, and the web in general, and still no solution.  I'm running an 
up to date Centos 4 system, pilot-link-0.11.8-8, and self-compiled 
jpilot 0.99.9.

Thanks for any help!