[CentOS] Trouble syncing Palm via USB

Fri Oct 20 14:57:17 UTC 2006
Phil Schaffner <Philip.R.Schaffner at nasa.gov>

On Tue, 2006-10-17 at 10:00 -0700, Marc D. Field wrote:
> Hi,
> I'm having trouble getting my Palm to sync with jpilot on my Centos 
> system via USB.  When I sync, I get this error in jpilot:
> pi_accept Illegal seek
> Exiting with status SYNC_ERROR_PI_ACCEPT
> Finished
> I have jpilot syncing fine with this Palm over the network, BTW.  For 
> USB, I set things up for udev as described on various websites.

That may be the problem.  My palm sync works fine as a user without any
mods to udev, as long as I initiate the sync on the palm and then click
the Sync button in jpilot within a few seconds.  I am in the uucp group.
My "serial port" is /dev/ttyUSB1 in jpilot/preferences/settings.

> Here 
> are the relevant ports & symlink (created and deleted automatically with 
> each sync attempt):
> lrwxrwxrwx  1 root root 7 Oct 17 09:09 /dev/pilot -> ttyUSB1
> crw-rw----  1 root uucp 188, 0 Oct 17 09:09 /dev/ttyUSB0
> crw-------  1 marc uucp 188, 1 Oct 17 09:09 /dev/ttyUSB1

Here are my ports:

[prs at wx1 ~]$ ll /dev/ttyU* /dev/pilot
ls: /dev/pilot: No such file or directory
crw-rw----  1 root uucp 188, 0 Oct 20 10:21 /dev/ttyUSB0
crw-rw----  1 root uucp 188, 1 Oct 20 10:21 /dev/ttyUSB1

> I added myself to the uucp group.  It doesn't look like this is a 
> permissions issue, does it?


> (I saw a message in the list's archives 
> indicating that one must start jpilot as root in order to sync, but this 
> doesn't make sense to me.)

No need to be root as long as you are in the uucp group.

> Any ideas as to what's going wrong?  Are others syncing Palm devices to 
> their Centos boxes via USB (and from normal user accounts)?
> I have tried other things, such as using a different USB port on the PC, 
> and having jpilot sync to /dev/ttyUSB0 and /dev/ttyUSB1 instead of the 
> /dev/pilot symlink.  I've also searched the jpilot mailing list 
> archives, and the web in general, and still no solution.  I'm running an 
> up to date Centos 4 system, pilot-link-0.11.8-8, and self-compiled 
> jpilot 0.99.9.

My (self-compiled) versions:


I see rawhide (my SRPM source) is still at


And EL5 beta is using

Perhaps 0.99.9 is too far ahead of the curve, or it is a permissions

Good luck,