[CentOS] Re: 4.4 yum update problem

Scott Silva ssilva at sgvwater.com
Fri Sep 1 21:31:59 UTC 2006

Les Mikesell spake the following on 9/1/2006 12:56 PM:
> On one of my machines yum hung up while installing the updates and
> could not be interrupted or killed.  I rebooted the machine the next
> day, but now a 'yum update' reports:
> Error: Missing Dependency: openssh = 3.9p1-8.RHEL4.12 is needed by
> package openssh-askpass-gnome
> and
> Error: Missing Dependency: rpm = 4.3.3-13_nonptl is needed by package
> rpm-build
> even though rpm -q says those version are installed:
> #rpm -q rpm openssh
> rpm-4.3.3-13_nonptl
> openssh-3.9p1-8.RHEL4.12
> Now what?
This came across yesterday, and it helped me;
I ran that script as well just a few minutes ago and it got rid of all
my dups. Everything seems to be good now, but I'll have to keep this all
in mind for the next time around.

The script is just this in case you still can't get to it:

for file in `rpm -qa --queryformat="%{NAME} %{ARCH}\n" | sort | uniq -c
| grep -v "  1 " | cut -c 9- | cut -d" " -f1`; do rpm -q --last $file |
tail -1 | cut -d" " -f1; done | grep -v gpg-pubkey | xargs rpm -e
 --justdb --nodeps 2> /tmp/dupes

Fix the wrap so it is on one line, you could even throw it in a script just in


MailScanner is like deodorant...
You hope everybody uses it, and
you notice quickly if they don't!!!!

More information about the CentOS mailing list