[CentOS] postfix pb with mass emails

John Summerfield debian at herakles.homelinux.org
Mon Sep 4 23:32:33 UTC 2006

sophana wrote:
> Unfortunately, I did the test some weeks ago, and the logs have been
> rotated away...
> I don't think I'd like to bother 3500 users again with my mass emails...
> If you have a solution to test this, without real email...
If you're serious about fixing this, then you need to be able to 
reproduce the problem at will. How else can you tell whether the 
problem's fixed?

It's especially more difficult to solve this problem if the evidence is 
lost; if your memory's anything near as bad as mine, you've forgotten 
important information, confused it and/or never noticed in the first 

You don't have to use real users, and you probably don't have to havr 
3500 addresses, but you do need some that work and some that don't.

Assuming you have your own LAN, you could use an alternative domain name 
and configure two or three hosts to receive email for that domain name.

I use the TLD "lan" for my testing and anything the world at large 
shouldn't see:
[summer at ns ~]$ host demo.lan
demo.lan has address
[summer at ns ~]$ host test.lan
test.lan has address
[summer at ns ~]$ host office.lan
office.lan has address
[summer at ns ~]$

You don't need separate hardware, in my case I could overlay 
on by configuring eth0:0 on the various machines:
sudo ifconfig eth0:0 netmask
and so on.

You will need to configure the zones you choose in bind. Read the docs 
if you need help here.



-- spambait
1aaaaaaa at coco.merseine.nu  Z1aaaaaaa at coco.merseine.nu
Tourist pics http://portgeographe.environmentaldisasters.cds.merseine.nu/

Please do not reply off-list

More information about the CentOS mailing list