[CentOS] LVM recovery questions

Garrick Staples garrick at usc.edu
Thu Jul 5 23:53:58 UTC 2007

Btw, your email client appears to be misconfigured as it fails to quote
previous email bodies.

On Thu, Jul 05, 2007 at 03:49:43PM -0700, Michael Mueller alleged:
> Thanks for your help.
> I tried the rescue mode; it only found what was on the new install of 4.3 single server cd;
> i tried adding mount /dev/hdb1 /export to fstab and rebooted again; /export/samba/netdisk0 was there - but it was just an empty file - probably because of the LV structure on the disk
> it seems to me that if a system is built under LVM and is comprised of multiple disks, recovery out to be quite easy; i must be missing something here;  with the pre-LVM partitioning, i would just mount the /dev/hdb1 and be on my way; i am hoping there is a similarly easy way to get my disk back into a file system

If you were directly mounting /dev/hdb1, then you weren't using LVM.

Perhaps hda was under LVM but hdb wasn't?

Try 'fdisk -l /dev/hdb' and try mounting the largest partition.

Garrick Staples, GNU/Linux HPCC SysAdmin
University of Southern California

Please avoid sending me Word or PowerPoint attachments.
See http://www.gnu.org/philosophy/no-word-attachments.html
09 F9 11 02 9D 74 E3 5B D8 41 56 C5 63 56 88 C0
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20070705/eabbacc5/attachment.bin

More information about the CentOS mailing list