[CentOS] upgrade aspell , glibc and glibc-common

Centos centos at unixplanet.biz
Wed Jun 27 17:15:32 UTC 2007

well, the version of aspell that I need to upgrade to is only built for 
contos 5
and I think that is the reason I get that error.
it seems that aspell-0.6 is not compiled for centos4 which was strange.

here is the error that i get,

warning: aspell-0.60.3-7.1.i386.rpm: V3 DSA signature: NOKEY, key ID 
error: Failed dependencies:
        libc.so.6(GLIBC_2.4) is needed by aspell-0.60.3-7.1.i386
        rtld(GNU_HASH) is needed by aspell-0.60.3-7.1.i386

do you think if i rebuild the rpm from scratch it will help ?

Jim Perrin wrote:
> On 6/27/07, Centos <centos at unixplanet.biz> wrote:
>> Hello
>> Is there any glibc-2.6 rpm available for centos 4.4.
> No. glibc is pretty core to the system, and upgrading it would likely
> require a massive rebuild of most other system packages. Upgrading
> glibc is a 'bad idea'
> How were you attempting to upgrade aspell? I can't imagine that it's
> specifically linked to a version of glibc, unless you're attempting to
> install an aspell rpm from a different release or distribution.

More information about the CentOS mailing list