[CentOS] Strange slowdown occasionally in CentOS 5.0

Bart Schaefer barton.schaefer at gmail.com
Sat Jun 30 17:56:25 UTC 2007

On 6/30/07, Johnny Hughes <johnny at centos.org> wrote:
> Mark Hull-Richter wrote:
> > For some reason, parts of my system are now slowing down to an
> > agonizing crawl from time to time.
> I don't think you are imagining things, as I tend to see similar things.
> Every time I see it though, it is firefox/seamonkey related ... and
> stopping and then restarting the browser has fixed the problem for me.

I haven't seen this kind of thing regularly, but the other day I was
trying to do some work that involved converting a couple of relatively
large (3 columns, 3500 rows) HTML tables into a spreadsheet.  I tried
to do this by loading each HTML document into FF, doing a "select all"
and then pasting into oocalc.

This eventually did work, but when I tried to "select all" in FF it
became unresponsive (watched in "top", it was consuming 95%+ of the
CPU) for minutes at a time.  The fist time this happened I was then
able to paste into oocalc, but on the second table I had to try three
times -- it would *seem* to have selected all the rows (as in, the
browser finally became responsive again and showed the whole page
highlighted) but the clipboard was empty (I could not paste).  If it
hadn't worked for the first table I wouldn't have tried as often as I
did on the second one.

I'm tempted to blame this on X (more likely the libraries, but
possibly something to do with the clipboard protocol) rather than on
Firefox.  However, I'm probably biased against Xorg because it still
goes AWOL for long periods at boot time if no network is available
(just this morning I resorted to installing caching-nameserver in
hopes that might help).

More information about the CentOS mailing list