[CentOS] imap problems; error accessing inbox and some other folders

Sat Mar 10 04:28:44 UTC 2007
Joe Klemmer <klemmerj at webtrek.com>

Hello all,

    First off, please let me apologize for cross posting this in both the
fedora and centos lists.

    I have just run into a problem with imap that's becoming a real issue.
 About two or three days ago some of the mail folders became
unusable/unreadable.  For instance, my inbox shows 41 unread messages when
I access it through pine on the server.  But if I imap into it from
evolution it shows only one unread message.  I tried thunderbird and kmail
as well as squirrelmail and these gave some variation of this kind of
error message:


The current command did not succeed.  The mail server responded: Invalid
messageset: -2147483648:*.

--------------------------- OR ------------------------------------------

The server couldn't find the message you requested.

Most probably your message list was out of date and the message has been
moved away or deleted (perhaps by another program accessing the same


    I tried rebuilding the imap directories under each app as well as
moving/renaming the .imap dir under $HOME/mail but to no avail.

The pertinent info is -

CentOS 4.4

kmail 1.9.5 (from KDE: 3.5.5-0.2.fc5 Fedora-Core)

    If there is any more info needed let me know and I'll post it.

    Please try and reply directly to me.  I will post a summery of what
was wrong and how it got fixed (if it does get fixed).

Thank you for any and all help,

Boring Home Page - http://www.webtrek.com/joe
See my blog, sumo game ranks and other interesting junk