[CentOS] system-display-config doesn't run right

Mon Mar 19 20:13:48 UTC 2007
Mark Hull-Richter <mhull-richter at datallegro.com>

This might be a gnome problem, but....


I've noticed that, on occasion (frequently), when I try to look at or
modify my display configuration, the Applications->System
Settings->Display doesn't come up.  It asks for the root password, which
I give it, and then nothing.


I ran system-config-display form the command line, but it dies thus:


[root at mhullrichter mhr]# system-config-display

* no cardMem, assuming 8192

* no cardMem, assuming 8192

Trying with card: VESA driver (generic)

* no cardMem, assuming 8192

Traceback (most recent call last):

  File "/usr/share/system-config-display/xconf.py", line 380, in ?

    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,

  File "/usr/share/system-config-display/xConfigDialog.py", line 566, in


TypeError: GtkLabel.set_text() argument 1 must be string, not None


I seem to be missing an argument from the call, but I'm not sure what
goes there, and even so, when I run it from the menu, shouldn't it have
the right data and run?




Mark Hull-Richter         Linux Kernel Engineer
(949) 680-3082 - Office     (949) 680-3001 - Fax     (949) 632-8403 -
mhull-richter at datallegro.com <mailto:mhull-richter at datallegro.com> 
www.datallegro.com <http://www.datallegro.com> 
85 Enterprise, 2nd Floor, Aliso Viejo, CA 92656


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20070319/c6c87262/attachment-0004.html>