[CentOS] Problems with screensavers / X config

Mon Mar 26 02:46:04 UTC 2007
Mark Hull-Richter <mhullrich at gmail.com>

On 3/25/07, Mark Hull-Richter <mhullrich at gmail.com> wrote:
> Then let's have a look at your xorg.conf and your Xorg.0.log.
> --
> Joshua Baker-LePain
> Department of Biomedical Engineering
> Duke University
> Well, the log file is 853 lines long with no timestamps, but here are
> a couple of recurring errors that look like they might be relevant:
> (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
> (WW) Open APM failed (/dev/apm_bios) (No such file or directory)
> I suspect the first is a key to this problem, but I have no idea where
> GLX is looking for the nvidia driver or why it would not be there.
> Quick review: when I finally got the system into init 3 state, I ran
> the nvidia installer, it compiled the driver on host and said
> everything wa fine.
> I have no clue what the second one means or why it would be happening.
>  The two errors are not directl connected to each other and appear
> with a random number and type of message in between.
> mhr
And of course I forgot to include the xorg.conf file, so I went and
read it.  There was this strange thing in the display section - there
were two described.  The first was the generic 800x600 display, and
the second was more like mine, so I though, why not comment that out?
Worst case, I'll have to reboot and fix it.  So I did, then brought it
back up to level 5, and lo and behol, the 3D functions are working,
the log has no more of those error lines, and my Gmail message editing
window doesn't have any more of those cursor droppings when I move
around without entering anything.

Does that mean I fixed it? (grin)

Thanks, Josh - I guess sometimes reading can help.  Good thing I
learnd how to, although not necessarily what or when....