[CentOS] CentOS5 and ipw2200

Dag Wieers dag at centos.org
Tue Nov 13 09:28:58 UTC 2007

On Mon, 12 Nov 2007, Christian Volker wrote:

> >> I tried to use DHCP, but the card didn't get assigned to any IP address.
> So I
> >> used the manual configuration which seemed to work fine during startup.
> But
> >> unfortunately not network connection could be made. So no ICMP ping
> packets
> >> where reaching the destination.
> >I have had a similar experience.  After your interface starts, check to
> >see if dhclient is running.  It seems that for some reason, even though I
> >have BOOTPROTO=dhcp in the interface configuration file, it doesn't get an
> >address, but if I run dhclient eth1 it gets an address immediately.
> Even when I configure it manually, I don't get any connectivity. So it
> doesn't seem to be related to DHCP here.
> But it could be related to the DHCP issue I'm seeing on FC8 and OpenSuSE10.2
> Thanks for the hint.
> So you have an ipw2200 running in CentOS5 without any issues? How did you do
> this? ;)

I have an ipw2200 as well in my Thinkpad T43.

I would suggest using NetworkManager instead of messing with iwconfig.

Do this:

	service NetworkManager restart
	chkconfig NetworkManager on

and then you should see a new applet-icon in Gnome. (if not, run nm-applet
as user)

NetworkManager works a bit like windows, it will tell you when it connects
and disconnects (also for wired) and you can easily select a wireless
nework and provide keys.

--   dag wieers,  dag at centos.org,  http://dag.wieers.com/   --
[Any errors in spelling, tact or fact are transmission errors]

More information about the CentOS mailing list