[CentOS] Sound problems on envidia 6510 in Compaq SR5110NX

Phil Savoie psavoie1783 at rogers.com
Mon Oct 1 02:28:35 UTC 2007

On September 30, 2007, Chuck Mattern wrote:
> Following up to myself, I have ruled out a hardware problem by booting
> the Fedora 7 Live CD and confirming that he card works under that
> distro.  I used the F7 /etc/modprobe.conf as a cheat sheet but still am
> not getting audio under CentOS 5.  I listed the loaded modules after
> rebooting and found that the sound drivers still had not loaded in spite
> of the modified modprobe.conf:
> alias scsi_hostadapter sata_nv
> alias eth0 forcedeth
> alias snd-card-0 snd-hda-intel
> options snd-card-0 index=0
> options snd-hda-intel index=0
> I ran modprobe snd-card-0 and all of the expected modules loaded as they
> did under F7 but still no audio output.
> I checked to be sure kudzu was seeing the device and it is:
> # kudzu -p
> ........
> class: AUDIO
> bus: PCI
> detached: 0
> desc: "nVidia Corporation MCP61 High Definition Audio"
> vendorId: 10de
> deviceId: 03f0
> subVendorId: 103c
> subDeviceId: 2a5c
> pciType: 1
> pcidom:    0
> pcibus:  0
> pcidev:  5
> pcifn:  0
> '''''''''
> I want to stay on CentOS for stability and longevity reasons.
> On Sun, 2007-09-30 at 19:24 -0400, Chuck Mattern wrote:
> > I've go a Compaq Presario (SR5110NX) that I've loaded CentOS 5 on and
> > all is well except for the sound card.  I understand that OSS supports
> > the chipset but it's not being detected an loaded properly and I've
> > invested a significant amount of time already.  I've probably got an old
> > supported card lying around here somewhere but I hat to give up on the
> > principal.  I would rather not download the proprietary drivers as that
> > will create a dependency when the kernel is upgraded and I'm shipping
> > this off to a remote law office where I'd like them to be a little more
> > self sufficient than having to have me log in and recompile each time
> > they upgrade a kernel.  Any experience or advise with this would be
> > appreciated.
> >
> > Regards,
> > Chuck

HI Chuck,

Don't mean to be out of line, but did you check to see if the audio mixer has 
not muted the device?  Perhaps run as root alsamixer and set your values then 
alsactl store ( I think) to store the settings?


More information about the CentOS mailing list