[CentOS] File retrieval from outside hangs, internally is okay, only Centos5 affected

Barry Brimer lists at brimer.org
Sun Oct 7 13:16:06 UTC 2007

> I have a really weird problem with some of my servers, namely all the
> ones running Centos5
> When I try to download a file from the server to a machine outside our
> Cisco 6500 router/firewall, the download hangs about half the times
> (15 out of 40) when less than half a megabyte into the transfer
> (varied from 76 kb to 496 kb).
> One server has a portchannel (Cisco speak for ethernet bundle), others
> do not, some use e1000, some use broadcom, I've tried httpd and scp
> transfers, I've tried from three different clients,
> Here's the really annoying part: the problem only occurs when
> downloading from outside the firewall, not when transferring files
> internally in the serverroom! And the switch is the firewall is a
> modular chassis, so the data comes over the same backplane regardless.
> And there's 42 files in /proc/net/sys/ipv4 which differ between EL4
> and Centos5, so I'm a little lost here

I don't know if this would help, but I remember reading a post about a 
problem with tcp window scaling.  To disable tcp window scaling add the 

net.ipv4.tcp_window_scaling = 0

to /etc/sysctl.conf and then run sysctl -p to activate your change.


More information about the CentOS mailing list