[CentOS] yum $releasever thinks it's 1 instead of 3

Jim Perrin jperrin at gmail.com
Wed Oct 10 13:08:19 UTC 2007

On 10/10/07, Steve Campbell <campbell at cnpapers.com> wrote:
> I just upgraded one of my Tao boxes to Centos 3. The usual procedure is
> to do a yum update twice, and all is fine.
> This time, I had to rebuilddb before I could run the second yum update,
> and once I started this, yum fails. It says that $releasever is "1.0".
> Now I realize I could manually edit my yum.conf and make it go to 3, but
> this may not fix the problem down the road. Can someone tell me where
> this variable is defined, and any suggestions on how to fix this
> problem, please? Might a reinstall of yum packages fix this, as a last
> resort?

Look in /etc/yum.conf and see what package it looks to for releasever.
It's probably not set to centos-release, or you don't have
centos-release installed. Mostly make sure that the package referenced
in yum.conf is the right one, and is installed.

During times of universal deceit, telling the truth becomes a revolutionary act.
George Orwell

More information about the CentOS mailing list