[CentOS] CentOS Plus PHP5 upgrade.

Guillermo Garron guillermo.fedora at gmail.com
Wed Sep 26 02:14:24 UTC 2007

On 9/24/07, David Mackintosh <David.Mackintosh at xdroop.com> wrote:
> On Mon, Sep 24, 2007 at 01:25:21PM -0400, David Mackintosh wrote:
> > I have some users who have a 64-bit CentOS 4.x install (current),
> > which was installed with @Everything and then some annoying packages
> > strategically removed (mrtg, pegasus*, mailman...) and they have
> > decided they have a need for php5.
> So I browsed back through the previous day's CentOS list traffic, and
> I find an email that sounds suspiciously close to my problem, with
> advice to check out
>   http://wiki.centos.org/Repositories/CentOSPlus/CentOSWebStack
> So I have followed those recommendations about the
> yum-priorities-plugin and now I'm in a deeper hole than I was when I
> started:
> --> Finished Dependency Resolution
> Error: Missing Dependency: php = 4.3.9-3.22.9 is needed by package php-pear
> Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DBD-Pg
> Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DBD-MySQL
> If anyone has any advice about either situation I'd appreciate it but
> I may have to resort to uninstalling everything and starting again.

Check this out

but what I had to do, was to put the same priority to CentOSPlus, run

yum install perl

and then back the priority to 2 again, and then install the rest of
packages I needed.

let me know if that helps.



More information about the CentOS mailing list