[CentOS] Unable to POST after suspend

Wed Sep 12 16:20:24 UTC 2007
Mark Rosenstand <mark at borkware.net>

On Tue, 2007-09-11 at 12:13 -0500, B.J. McClure wrote:
> > On Tue, 2007-09-11 at 13:19 +0000, gjgowey at tmo.blackberry.net wrote:
> > > I have one idea that may work.  Try seeing if your bios supports a
> > bios upgrade floppy (it would say so in the owners manual).  Now by
> > bios upgrade floppy I don't mean the usual type that use an os.
> > There are some that the bios will directly read from without an os
> > being used.  The concept is to recover from failed bios upgrades.
> > The reason I suggest this is because I think the setting that's
> > keeping your system off is hiding in your bios' acpi table and I
> > don't think a bios reset will dump it, but a bios upgrade might.
> > 
> > My motherboard do support such BIOS upgrades (really nice since it's
> > OS
> > independent) but you need to get to the POST before you can ask it
> > to
> > search for the floppy.
> > 
> > But it won't power on at all. The CPU FAN doesn't start, the disk
> > doesn't rotate, the monitor doesn't get any signal. The only thing
> > that
> > indicates the slightest sign of life is the LED on the motherboard
> > and
> > my keyboard if I press Num Lock.
> > 
> > Is there something on the motherboard I can disconnect to reset the
> > ACPI
> > table?
> Seems to me there is room to suspect a hardware issue instead of acpi.
> I would confirm power supply connector to mainboard by removing and
> reinserting until properly seated.  Also would confirm two wires from
> power button on case/chassis are correctly connected to proper pin
> terminals at edge of mainboard.  If still no joy, would swap a known
> good power supply.  If that fails, you might try removing the power
> switch leads from the pin terminal strip and use a phillips
> screwdriver blade or other appropriate tool to short the proper pins
> momentarily to start the beast.  I have replaced three bad power
> switches in the recent few years, so they do fail.

In its current configuration, this system has survived over 500 boots.
It has failed this one time, which is the only time I've tried to use
suspend. I've tested every component in other PC's and they all seem to
function properly, except the motherboard.

My theory is that the suspend succeeded but perhaps the BIOS settings
don't define any way to switch state SLEEP -> ON. The system has been
without power and BIOS battery over night, but it hasn't changed

Do anybody know of a way to force wake up?