[CentOS] iSCSI + CentOS 5.1 +_netdev problem

Mon Apr 21 08:43:34 UTC 2008
Santi Saez <santi at hostalia.com>

Dear Srs,

I'm trying to automount an iSCSI device at system startup, this is  
the configuration:

- CentOS 5.1, with kernel 2.6.18-53.1.14.el5PAE, i686 arch
- iscsi-initiator-utils
- iSCSI target is a Infortrend A16E-G2130-4

I have solved the "initial_login_retry_max" problem [1] and Open- 
iSCSI logs into Infortrend target without problems, with 10 retries  
in the parameter, but the partition is not automounted.

Start scripts order appears OK:

# ls -1 /etc/rc3.d/S*

But "_netdev" marked iSCSI device is not mounted, this is the fstab  

LABEL=/vz /vz ext3  
_netdev,rw,noatime,nodiratime,commit=60,data=writeback 0 0

I have tried using LABELs, UUIDs, device names in fstab file.. and  
the problem is the same.

If I put a "mount /vz" into "/etc/rc3.d/S99local" partition is  
mounted without problem..

I think the problem is in the "netfs" start script, I see no option  
to mount "_netdev" marked entries.. only a call to the command:

fsck -A -T -R -a -t opts=_netdev

I have solved the problem adding a "sleep 1" before the fsck execution:

echo $STRING
sleep 1
fsck -A -T -R -a -t opts=_netdev

Anyone with the same problem? What can be wrong? I have no problem  
with the same scenario on CentOS 4.6.. thanks!!


Santi Saez