[CentOS] Apache Authorization Access Control - location ofhtpasswd in Centos 5.1?

Sun Apr 6 14:32:07 UTC 2008
Barry Brimer <lists at brimer.org>

On Sun, 6 Apr 2008, Pam Astor wrote:

>>>>> I tried creating a password file by executing htpasswd -c /passwd/passwords> > famsite but apparently htpasswd is not in my path, I'm getting the "cannot> > create file /passwd/passwords famsite" error.> >> >> >> > Anyone know where the default location of htpasswd is on a centos 5.1> > install? Or how to generate a password file on a centos 5.1 install?> > > There's a utility called 'which' you can use to discover the location> of certain apps you want to learn about.> > Thanks! Ok I ran /usr/bin/htpasswd -c /passwd/passwords famsite as root, and still got> > the cannot create file error.> > Does the /passwd directory exist? It does now.  It did not when I first ran the command, however I just created the directory /passwd/passwordsand re ran the command as root, and still no luck.
> PS, I think there are some permission requirements for the directory and file as well.  I think they have to be owned by 'apache'.
> The dirs were owned by root, so I just chown'ed to apache, re ran the command
> /usr/bin/htpasswd -c /passwd/passwords famsite, still no luck.

Just for the sake of simplicity, please create your htpasswd file in the 
tmp directory and copy it elsewhere.  Any user can write in /tmp .. 
although if you are using the root user this should not be an issue.