[CentOS] 'initrd' image of CentOS (domU) on Ubuntu (dom0)

S.A. qmt9z3 at yahoo.com
Sat Aug 2 14:04:42 UTC 2008

> > Could I do it on any system or a system with
> similar
> > architecture?
> I don't know.
> Is it possible to generate the initrd
> > using a live CD?
> Probably.
> You may want to have a look at the jailtime.org
> images. They should have a 
> complete CentOS 5.2 or 5.1 image.
> Kai

I did look at jailtime.org. Their image file seems
to contain everything excepting for vmlinuz and 
initrd. You may need to generate 'initrd' image on
the machine itself, but vmlinuz could have been
packaged with the rest, but they didn't. I am
sure there is a reason for it.

I tried to go thru a different route to accomplish
the above. I tried to use instructions from:

I was trying: "yum --installroot=/xen -y groupinstall
and I got the error:
(373/375): openldap-2.3.2 100%
|=========================| 294 kB    00:05     
(374/375): dhcdbd-2.2-1.e 100%
|=========================|  61 kB    00:00     
(375/375): python-2.4.3-2 100%
|=========================| 5.9 MB    00:12     
warning: rpmts_HdrFromFdno: Header V3 DSA signature:
NOKEY, key ID e8562897
Importing GPG key 0xE8562897 "CentOS-5 Key (CentOS 5
Official Signing Key) <centos-5-key at centos.org>" from
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 188, in
  File "/usr/share/yum-cli/cli.py", line 364, in
    if self.gpgsigcheck(downloadpkgs) != 0:
  File "/usr/share/yum-cli/cli.py", line 464, in
    self.getKeyForPackage(po, lambda x, y, z:
line 2571, in getKeyForPackage
"/var/lib/python-support/python2.5/yum/misc.py", line
278, in import_key_to_pubring
    ctx = gpgme.Context()
NameError: global name 'gpgme' is not defined
I am using version 3.2.12-1.1.

Any suggestions on what could be causing the above.
Is it possible to start from where it left off
(ie it already downloaded the required packages)?



More information about the CentOS mailing list