[CentOS] CentOS 5.2 - Nautilus - file types are not associated with an action and icons are not displayed

Thu Aug 7 23:23:33 UTC 2008
Vaclav Mocek <little.owl at email.cz>

MHR wrote:
> On Thu, Aug 7, 2008 at 3:51 PM, Vaclav Mocek <little.owl at email.cz> wrote:
>> I use CentOS 5.2 as a desktop and the Gnome Nautilus doesn't display icons
>> related to the file types and all associated actions ("open with") are lost.
>> It is so bad, that the desktop shortcuts are displayed as ordinary files
>> "Filesystem.desktop" or "openoffice.org-1.9-calc.desktop", and when I click
>> on them, the Nautilus wants to know what it should do with these files.
>> The problem emerged after I installed the  new kernel (2.6.18-92.1.10.el5)
>> and  uninstalled packages "joystick", "slrn" and "planner".  All user
>> accounts have the same problem, when I run the Nautilus as root (sudo
>> nautilus), it works fine => probably some access restrictions.
>> I run the Nautilus with strace, but the output is too messy to provide some
>> sensible information. Any hint what to do is welcomed.
> Check the permissions on all files and directories in anything under
> /usr that has "gnome" in it.  Chances are something is screwed up
> there.
> Also, double check your root's umask - it should be 2 (and NOT 22 or
> 27 or 77) while you're installing.
> I ran into something like this a while back when I changed the root
> umask to something other than 2, and it really screwed up all my
> settings until I changed the permissions and umask back.
> mhr
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

thanks a lot, the problem was solved - there is necessary to reinstall 
the package shared-mime-info

rpm -ivh --force shared-mime-info-0.19-5.el5.i386.rpm

and after that it works fine again. It was a problem of Fedora Core 6 - 
the time from the time it was broken after an update and it seems that 
CentOS has the same problem as well. Before I sent my mail, I checked 
the integrity of the package shared-mime-info and time stamps of its 
files, and everything was OK. I still don't know the real reason, 
however it works.

Best Regards