[CentOS] Missing fonts for tightvnc

Wed Aug 13 16:14:03 UTC 2008
Toby Bluhm <tkb at midwestinstruments.com>

Robert Moskowitz wrote:
> Toby Bluhm wrote:
>> Robert Moskowitz wrote:
>>> You would think installing via yum would handle dependencies, but 
>>> perhaps fonts are not managed like dependencies.....
>>> Anyway, I installed tightvnc to test out its IPv6 support.
>>> Installed ok (after I erased regular vnc). But when I tried to start 
>>> it, I got 5 warnings about:
>>> Font directory '/usr/X11R6/lib/X11/fonts/misc' not found - ignoring 
>>> (then the same message for Speedo, Type1, 75dpi, and 100dpi).
>>> Then a fatel server error about: could not open default fount 'fixed'
>>> So I looked in the repos (curtesy of yumex) and did find a few 75dpi 
>>> a 100dpi fonts, but there seemed to be a lot of these two. I 
>>> installed a ocuple of them and tried again. Got the same errors.
>>> So how do I fix this one?
>> Perhaps vnc can't talk to the xfs daemon - IPv6 or firewall related? 
> Perhaps. What ports does xfs use? Why does it work for vncserver (on 
> IPv4 only of course)?

7100 I think . . .

grep xfs /etc/services
xfs             7100/tcp                        # X font server

  . . yes

> But I stopped both iptables and ip6tables and the same error messages.
> And installing OpenOffice did not 'fix' things. Perhaps setting symlinks 
> may be needed.

I remember playing games with Matlab to get it to find it's own fonts. I 
think it went something like:

mkdir <fontdir>
cp fonts* <fontdir>
mkfontdir <fontdir>
Add <fontdir> to /etc/X11/fs/config

Like you say, maybe just a link to /usr/share/X11/fonts/misc would do 
the trick.

Perhaps a vnc/X startup script somewhere is hardcoded?

Toby Bluhm
Alltech Medical Systems America, Inc.