[CentOS] Missing fonts for tightvnc

Wed Aug 13 23:48:21 UTC 2008
Rob Lockhart <rlockhar at gmail.com>

On Wed, Aug 13, 2008 at 12:14 PM, Toby Bluhm <tkb at midwestinstruments.com> wrote:
> Robert Moskowitz wrote:
>> Toby Bluhm wrote:
>>> Robert Moskowitz wrote:
>>>> You would think installing via yum would handle dependencies, but
>>>> perhaps fonts are not managed like dependencies.....
>>>> Anyway, I installed tightvnc to test out its IPv6 support.
>>>> Installed ok (after I erased regular vnc). But when I tried to start it,
>>>> I got 5 warnings about:
>>>> Font directory '/usr/X11R6/lib/X11/fonts/misc' not found - ignoring
>>>> (then the same message for Speedo, Type1, 75dpi, and 100dpi).
>>>> Then a fatel server error about: could not open default fount 'fixed'
>>>> So I looked in the repos (curtesy of yumex) and did find a few 75dpi a
>>>> 100dpi fonts, but there seemed to be a lot of these two. I installed a
>>>> ocuple of them and tried again. Got the same errors.
>>>> So how do I fix this one?
>> But I stopped both iptables and ip6tables and the same error messages.
>> And installing OpenOffice did not 'fix' things. Perhaps setting symlinks
>> may be needed.
> I remember playing games with Matlab to get it to find it's own fonts. I
> think it went something like:
> mkdir <fontdir>
> cp fonts* <fontdir>
> mkfontdir <fontdir>
> Add <fontdir> to /etc/X11/fs/config
> Like you say, maybe just a link to /usr/share/X11/fonts/misc would do the
> trick.
> Perhaps a vnc/X startup script somewhere is hardcoded?

Robert, I noticed the same thing, so what I did is the following:

cd /usr/X11R6/; mkdir lib; cd lib; ln -s /usr/share/X11 .

Now try it.  Seems like the repository from which I got TightVNC has
issues in directory compatibility....  but at least I got it working.

I didn't have a misc fonts directory, and my $HOME/.vnc/xtartup has:

# Red Hat Linux VNC session startup script
exec /etc/X11/xinit/xinitrc

If that still doesn't work, I'll post the /etc/init.d/vncserver script
that works for me (possibly from an older install of tightvnc - 1.2.9
I believe).

If there's a more elegant solution, someone please let us know!  :-)