[CentOS] Yum corrupting RPMs

Mon Aug 25 13:35:14 UTC 2008
Ross S. W. Walker <RWalker at medallion.com>

On Aug 24, 2008, at 9:25 PM, "Tom Lanyon" <tom at netspot.com.au> wrote:

> Hi list,
> Trying to upgrade someone's workstation here to 5.2 (was installed  
> from a 5.0 DVD I think).
> The RPMs on our internal mirror are in-tact and pass a 'rpm -- 
> checksig' test, yet when I run a 'yum upgrade' a large portion of  
> them are corrupted and fail the GPG check.
> This seems to be isolated to yum, as downloading the RPM directly  
> via FTP with wget or lftpget provides an RPM that *does* pass the  
> GPG check.
> I have upgraded key packages to the latest version (eg. yum upgrade  
> 'yum*') and tried again to no avail.
> Anyone seen this before?

Make sure the mime type for .rpm files is text/plain and not x- 


This e-mail, and any attachments thereto, is intended only for use by
the addressee(s) named herein and may contain legally privileged
and/or confidential information. If you are not the intended recipient
of this e-mail, you are hereby notified that any dissemination,
distribution or copying of this e-mail, and any attachments thereto,
is strictly prohibited. If you have received this e-mail in error,
please immediately notify the sender and permanently delete the
original and any copy or printout thereof.