[CentOS] Problems with writing Dual Layer DVD

Wed Aug 27 18:13:46 UTC 2008
Chris Geldenhuis <chris.gelden at iafrica.com>

William L. Maltby wrote:
> On Wed, 2008-08-27 at 19:38 +0200, Chris Geldenhuis wrote:
>> Hi,
>> I am running Centos 4 (fully updated on this box).
>> I removed the old DVD writer (/dev/hdc) and installed a new LG GH20 
>> "Internal Super Multi DVD Rewriter" with a SATA interface - this shows 
>> up as /dev/scd0.
>> When I insert a pre-recorded DVD autorun mounts it and displays the 
>> contents without any hassles. It appears to me that the required kernel 
>> modules are loaded - as copied below from lsmod output.
>> sata_nv                18629  0
>> libata                111261  1 sata_nv
>> sd_mod                 17217  0
>> scsi_mod              125261  3 sr_mod,libata,sd_mod
>> I am using Verbatim DVD-RDL blanks.
>> When I try to write a pre-recorded iso to the DVD I get the following 
>> error message:
>> [user at test]$ growisofs -dvd-compat -Z /dev/dvdwriter=<pre-recorded>.iso
>> :-( /dev/dvdwriter: media is not recognized as recordable DVD: 10015
>> I have tried to do this as root with the same result. /dev/dvdwriter is 
>> a link to /dev/scd0 and has full read/write/execute permissions.
>> Output of growisofs -version:
>> * growisofs by <appro at fy.chalmers.se>, version 5.21,
>>   front-ending to mkisofs: mkisofs 2.01 (i686-pc-linux-gnu)
>> Any suggestions will be welcome - if any further information is required 
>> I will do my best to supply it.
> I'm *really* a novice at this, but the first time I tried to record a
> DVD (I use cdrecord) I learned that the media needed to be formatted
> first. I don't know if what your using is already formatted, if your
> software does it for you or if it's even needed.
> Using the cdrecord software, there are flags that will let me know.
>> I have Googled with the error message but only get reports of this 
>> problem and no solutions.
>> TIA
>> ChrisG
>> <snip>
Hi Bill,

Thanks for the quick response - I did try to format with dvd+rw tools 
but also got a respnse that the media was not recordable. AFAIK it 
should not be required.

 From reading your many and interesting posts to this list I realize 
that we must be contemporaries (possoibly I started programming before 
you - circa 1963 on a ICL1500 aka RCA 301 in assembler or directly 
punching machine code into punch cards).

I do appreciate your responses as they always  are helpfull and when 
them flame wars flare up you remain sensible.

Thanks again