[CentOS] CD burning issues & questions

William L. Maltby CentOS4Bill at triad.rr.com
Wed Dec 31 18:37:34 UTC 2008

On Wed, 2008-12-31 at 10:27 -0800, MHR wrote:
> I have been having some strange results trying to burn CDs under
> CentOS.  I don't think they are hardware related because I have had
> some success, in fact most of this usually works.
> I use k3b for most of my CD and DVD writing - it seems to work fairly
> well (well, except for wrecking my installation a few weeks ago when
> it crashed my installation and I had to reinstall to get it back, but
> that's old news).
> Yesterday, of my work desktop (32-bit), I tried to burn a CD with k3b.
>  The system hung as soon as I clicked on the start button in the burn
> menu.  I did not want another case of wrecked system, so I rebooted
> (no other way to interrupt it) and all went well, except that I didn't
> even try to burn the CD.  (I used my other, backup desktop, and it
> worked fine over there - hmm....)
> Then, last night, on my home desktop (64-bit), which is usually solid
> as a rock, no problems whatsoever (I said "usually"), I had similar
> problems, though not quite as bad.  I was trying to erase some CD-RWs,
> and I kept getting errors, both from k3b and cdrecord, claiming that
> they could not lock the drive for exclusive access (because another
> process was accessing the device).  This is really annoying because
> I've tried this one several CD-RWs, and they all get the same error.
> Since k3b doesn't include a facility to add data to an already written
> CD or DVD unless there's a specific project for it (which I don't have
> 'cuz the CDs were written under Window$ or with projects I didn't
> keep).
> Any ideas/suggestions?

As to the "in use" part, I'll make a SWAG (Scientific Wild-Ass Guess).

With a normal desktop, when you insert a CD/DVD that has something
recognizable on it, an "automount" occurs that gives you access to the
thing from your desktop. I know notthing about the k3*, so I don't know
if the following is possible.

Is it possible that it is mounted as another user? If it is mounted at
all, does k3* allow you to erase, write, etc? I would think that it
would need to be un-mounted for that to occur.

That's all I can think of. Can you right-click on the icon and see what
the system thinks about it? What does a mount command show?

> Thanks.
> mhr
> <snip>

Sorry I have nothing more knowledgeable. I always use the cdr tools for
my stuff.


More information about the CentOS mailing list