[CentOS] "installation method" (CentOS 5.2)

Herta Van den Eynde herta.vandeneynde at gmail.com
Mon Jul 7 11:41:47 UTC 2008

2008/7/7 Dag Wieers <dag at centos.org>:
> On Mon, 7 Jul 2008, Herta Van den Eynde wrote:
>> I'm trying to install CentOS 5.2 on a Dell PE 1850 via the DRAC 4
>> card, with CentOS-5.2-i386-bin-1of6.iso mounted as virtual media.  At
>> the boot prompt, I hit <Enter>, which should start the graphical
>> installation, but it starts off with a text installation.  I am asked
>> - whether I want to test the media, which I skip
>> - what language I want to use - I select English
>> - what keyboard I have - I select us
>> - the installation method - "What type of media conatins the packages
>> to be installed?"
>>  I have the choice between
>>  - Local CDROM
>>  - Hard drive
>>  - NFS image
>>  - FTP
>>  - HTTP
>>  but not virtual CDROM.
>> How can I get it to install from the virtual CDROM? (and no, choosing
>> Local CDROM doesn't work).
> Because the operating system does not know this is a "virtual" CDROM. The
> interface looks very real to it. It should work with Local CDROM though.

Well, I tried several times.  When I select "Local CDROM", I get a new
screen with header "CD Not Found" and text "The CentOS CD was not
found in any of your CDROM drives.  Please insert the CentOS CD and
press OK to retry."

>> Why is the question there in the first place?  It got that far using
>> the virtual media, so why not simply continue using it?
> I think that fails because for some reason your (virtual) CDROM driver
> failed to load. Therefor the "generic" boot installation does not detect it
> is booting from the (virtual) CDROM and asks the question.

Then how can it even start the installation?

>> P.S.  CentOS 5.1 doesn't have this issue, but I just erased the 5.1
>> isos, so I'm hoping that I won't need to reload them all.
> It could help us to find out whether this issue exists with RHEL5.2 as well
> and what the (virtual) CDROM interface is. Is it a USB cdrom device, or some
> other device ?

Just downloaded Red Hat EL 5.2, and it has the same issue.  I suppose
this means I have to take it up with Red Hat?

I don't understand how DRAC works.  I download the iso image to the
harddrive of my PC, connect to the DRAC using a webbrowser (over
https), and select to serve that iso image as a virtual CD-ROM.
I once tried to serve an iso image to a system that was already
installed, hoping to be able to use it on the system, but I never
found out to what device file it got connected.

Kind regards,

> --
> --   dag wieers,  dag at centos.org,  http://dag.wieers.com/   --
> [Any errors in spelling, tact or fact are transmission errors]

More information about the CentOS mailing list