[CentOS] Back to my Xwindows kernel panic

Robert Moskowitz rgm at htt-consult.com
Mon Jul 7 20:07:04 UTC 2008

Have some important (I hope) data points Johnny,

Johnny Hughes wrote:
> Robert Moskowitz wrote:
>> Johnny Hughes wrote:
>>> Robert Moskowitz wrote:
>>>> I have a newly built drive with 5.2 fresh install (that I will be 
>>>> cloning shortly) in my DECtop and it is failing with X the same way 
>>>> the upgrade from 5.1 drive did (not too supprising there).
>>>> In 5.1 X worked.  I could startx from init 3 and get into GNOME.  
>>>> Also VNC into the box and have a GNOME screen.  With 5.2, I get a 
>>>> kernel panic.  Well I guess it is a kernel panic because once I run 
>>>> startx from the console, my SSH session to the box from my notebook 
>>>> is frozen.
>>> <snip>
>>> Try 16bit X instead of 24bit (replace the 24 in xorg w 16) and see 
>>> if that helps ... 
>> OK.  I will try this shortly.
> Did this work.
>>> also, you can boot the older kernel from 5.1 and see if that helps. 
>> I did try that on the system I upgraded from 5.1.  No difference 
>> still paniced.
> If it still panics then it does not seem to be a kernel module issue, 
> but something else.  That would be very strange.
> I guess some kind of compile issue in xorg could do this, though not 
> sure.

I just built a new Centos 5.1 install (I picked up 5 40Gb Hitachi 2.5" 
drives last week, tired of not having enough drivers for different tests).

I am using the vesa_drv.so driver.  This works just fine on 5.1.

In the Centos 5.2, this driver is unchanged.  Same date and filesize.  
Now a number of the video driver files are unchanged from Centos 5.1, 
but Generic VESA compliant is how Centos is handling the National 
Semiconductor Geode video in my DECtops.

I noticed there is a vesa.h file with a filesize of ZERO.  But in the 
case of the system upgraded from 5.1 to 5.2, it had this file for the 
5.1 kernel as well as for the 5.2, so I don't think this is important.

One more fact:  When I do a startx, I see some messages, but they are 
not written to any file I can find, nor are they visible when the system 

Other oddities about this system.  It has 2 sets of 2 USB ports.  In 5.1 
you MUST have the KVM USB keyboard plugged into the USB port labled for 
the keyboard (otherwise no keyboard detected).  This is not necessary 
for 5.2.  But if you put the keyboard into some other USB port (say the 
one with the printer icon), if you do not have the KVM 'focused' on the 
system while it is booting, it appears hung with no video (for either 
5.1 or 5.2 if it is plugged into the keyboard USB, it can boot while the 
KVM is 'focused' on another system).  Wierd.

More information about the CentOS mailing list