[CentOS] Back to my Xwindows kernel panic

Robert Moskowitz rgm at htt-consult.com
Sun Jul 6 21:07:39 UTC 2008


Johnny Hughes wrote:
> Robert Moskowitz wrote:
>> Johnny Hughes wrote:
>>> Robert Moskowitz wrote:
>>>> I have a newly built drive with 5.2 fresh install (that I will be 
>>>> cloning shortly) in my DECtop and it is failing with X the same way 
>>>> the upgrade from 5.1 drive did (not too supprising there).
>>>> In 5.1 X worked.  I could startx from init 3 and get into GNOME.  
>>>> Also VNC into the box and have a GNOME screen.  With 5.2, I get a 
>>>> kernel panic.  Well I guess it is a kernel panic because once I run 
>>>> startx from the console, my SSH session to the box from my notebook 
>>>> is frozen.
>>> <snip>
>>> Try 16bit X instead of 24bit (replace the 24 in xorg w 16) and see 
>>> if that helps ... 
>> OK.  I will try this shortly.
> Did this work.

I first edited /etc/X11/xorg.conf and set the screen depth to 16.  That 
did not work.

Then I tried system-config-display --reconfig  that failed.

I added --set-depth=16 --set-videoram=0 and still failed.

>>> also, you can boot the older kernel from 5.1 and see if that helps. 
>> I did try that on the system I upgraded from 5.1.  No difference 
>> still paniced.
> If it still panics then it does not seem to be a kernel module issue, 
> but something else.  That would be very strange.
> I guess some kind of compile issue in xorg could do this, though not 
> sure. 
Am I going to have to build a 5.1 system and see what device driver it 
is using???

More information about the CentOS mailing list