[CentOS] Flaky desktop audio behavior.

William L. Maltby CentOS4Bill at triad.rr.com
Wed Jul 9 19:20:10 UTC 2008

On Wed, 2008-07-09 at 11:25 -0700, nate wrote:
> William L. Maltby wrote:
> >
> > I'll see if I can ID a plugin in the next pass.
> The plugins themselves won't show up, in my case it just said firefox
> was using it. And I recall getting audio from flash earlier in the
> day so thought it still might be using it, and I happened to be right,
> after disabling the plugin the lock on the device was released.
> Since nothing is using the sound device, I'm not sure what else to
> check, short of permissions, at one point a few years ago it wasn't
> uncommon for the permissions of devices such as sound devices etc
> to get automatically changed to the person logged in. Not sure what
> caused it or why, or if anything still does it anymore. But if your
> user doesn't have access to the device I would think similar behavior
> would occur.

Well, that was involved partly. The other user owned all the
devices /dev/{gpmctl,mixer,audio,adsp,snd} *and* floppies, HD,
nvidia, ...

So I ran 

   find /dev -user bill -exec chown hardtolove {} \;

which I really shouldn't (I know better). But that did provide a small

I can now open the Volume Control Panel (for a lurking friend, that is
VCP   ;-)

I still can't open the volume slider that drops down from the little
speaker icon. So something is better, something still not fixed.

> So, check permissions on /dev/snd/* and /dev/dsp, another thing I do
> to test is run a command line program that generates a sound(I
> use mpg123 out of habbit which plays mp3 files), and see if you
> notice any permission denied type errors.

Will do. Signing off to find out where I can get mpg123. I think I'll
pop a CD in again first and see what I can doo-dah, doo-dah with that.


> nate
> <snip sig stuff>

Thanks for following up!

More information about the CentOS mailing list