[CentOS] Flaky desktop audio behavior.

William L. Maltby CentOS4Bill at triad.rr.com
Wed Jul 9 19:45:29 UTC 2008

On Wed, 2008-07-09 at 15:20 -0400, William L. Maltby wrote:
> On Wed, 2008-07-09 at 11:25 -0700, nate wrote:
> ><snip>

> Well, that was involved partly. The other user owned all the
> devices /dev/{gpmctl,mixer,audio,adsp,snd} *and* floppies, HD,
> nvidia, ...
> So I ran 
>    find /dev -user bill -exec chown hardtolove {} \;
> which I really shouldn't (I know better). But that did provide a small
> gain.
> I can now open the Volume Control Panel (for a lurking friend, that is
> VCP   ;-)
> I still can't open the volume slider that drops down from the little
> speaker icon. So something is better, something still not fixed.
> > 
> > So, check permissions on /dev/snd/* and /dev/dsp, another thing I do
> > to test is run a command line program that generates a sound(I
> > use mpg123 out of habbit which plays mp3 files), and see if you
> > notice any permission denied type errors.
> Will do. Signing off to find out where I can get mpg123. I think I'll
> pop a CD in again first and see what I can doo-dah, doo-dah with that.

Ahhhhh! Music to my ears!

CD is playing alright. Volume Control Panel mute, volume, balance all
work. In *my* original thread (not the one from ech - Jim?), I couldn't
even open the Volume Cont... crap that's too long - VCP  ;-) (you know
who you are!)

So, I suspect we have achieved bug nirvana. ISTM that the problem is
isolated to Gnome or it's interface to the system *or* a failure in some
OS component.

 1) Gave (properly?) ownership of the devices to a user other than the
desktop owner (NB: *if* it is legal for a user other than desktop owner
to use the facilities because the user is "in the desktop", being
invoked from a Gnome terminal, then the device ownership should be given
to the user of the device, just as with tty devices).
 2) When the using application(s) are terminated, the devices ownership
should be returned to root, as with tty devices, or back to the desktop
user (if that user ever owned them *before* the devices were used -
which they weren't in this case) allowing later allocation to another
user again and making them also available for the desktop user.
  3) When ownership of the devices were manually changed to root owner,
*part* of the desktop facilities began operating normally.
  4) Only part not working now is the volume control application out of
the speaker icon on my panel.
  5) As you suspected, lookie here!

    # cd ~hardtolove;find . -user bill -ls
      16646219 7948 -rwxr-xr-x   1 bill     bill      8119784 Nov 20
            2007 ./firefox/plugins/libflashplayer.so
      16646218    8 -rw-r--r--   1 bill     bill          856 Dec 15
            2006 ./firefox/plugins/flashplayer.xpt

    The Q now is will changing ownership of these affect the volume
slider? Shouldn't? First one is an LSB shared object, second one is

Anyway, with your (and all the others too) help, we have a reproducible
situation and some clues.

Before I write a bug report (after seeing that one doesn't exist),
anything else you think I could look for or try?

> > 
> > nate
> ><snip sig stuff>

Thanks again,

More information about the CentOS mailing list