[CentOS] Finding a python module

Robert Moskowitz rgm at htt-consult.com
Fri Jul 11 13:42:09 UTC 2008

Oh, wow, is my system hosed now....

Filipe Brandenburger wrote:
> On Fri, Jul 11, 2008 at 9:08 AM, Robert Moskowitz <rgm at htt-consult.com> wrote:
>> Error: Missing Dependency: python(abi) = 2.5 is needed by package hipl-lib
>> Centos 5.2 provides python 2.5.1.
> Are you sure?
> On an up to date system:
> # cat /etc/redhat-release
> CentOS release 5.2 (Final)
> # rpm -q python
> python-2.4.3-21.el5
> # rpm -q --provides python | grep -Fw 'python(abi)'
> python(abi) = 2.4
> You should look at where your friend got this Python from.
Some more testing shows

# python -V
Python 2.4.3

as well. He had me download the 2.5.1 source for Python and compile it. 
Of course that broke the previously installed rpms, like yum!

I am going to either have to find 2.5 that I can install on Centos (from 
a Fedora box), but that will most likely break even more things. Or get 
him to build a Centos box and do the build there...

More information about the CentOS mailing list