[CentOS] libstdc++.so.5 for xten voip phone

Greg Bailey gbailey at lxpro.com
Wed Jul 30 14:14:25 UTC 2008

Robert Moskowitz wrote:
> Greg Bailey wrote:
>> Robert Moskowitz wrote:
>>>>> Which rpm has libstdc++.so.5?
>> $ rpm --whatprovides /usr/lib/libstdc++.so.5 -q
>> compat-libstdc++-33-3.2.3-61
>> There's many ways to do this, but "yum install compat-libstdc++" 
>> should be all you need.
>> xten works fine for me (at least on CentOS 4 and 5) 
> And not working at all for me on Centos 5.2. It wants the so.5, and I 
> have the so.6....
> I can add compat-listdc++-33 when I have libstdc++-4.1.2-42.el5.i386.rpm?

Yes.  That's why the "compat-*" library RPMs are packaged the way they 
are; to provide applications like xten the shared libraries that are an 
older version than the default.  Most of the time, they're just .so 
files, but in the case of compat-gcc, compat-glibc, etc., Red Hat 
supplies enough compatibility "glue" so that applications targeted for 
version 4 can be supported on version 5, etc.


More information about the CentOS mailing list