[CentOS] Apache jserv monitoring?

Sean Carolan scarolan at gmail.com
Tue Jun 17 14:55:56 UTC 2008

>>> Sounds similar to the mod_jk connector in apache to connect to
>>> tomcat. When I had to deal with this I setup a dedicated apache
>>> instance on each system running tomcat whose sole purpose for
>>> existence was for testing that connector.

We have decided to take this tactic and set up a dedicated apache
instance on each server simply for monitoring the local java process.
I have run into a snag, however and I'm not sure what to do next.  At
first I attempted to install the mod_jserv rpm but that didn't work:

[scarolan at pstest-app13:~]$ sudo rpm -ivh ApacheJServ-1.1.2-1.i386.rpm
error: Failed dependencies:
        apache >= 1.3.6 is needed by ApacheJServ-1.1.2-1

Ok, so next thing I tried was compiling the module from source code:

[scarolan at pstest-app13:~/ApacheJServ-1.1.2]$ ./configure

[bunch of automake stuff removed]
checking for Apache source directory (assume static build)...
configure: error: Directory  is not a valid Apache source distribution

I have installed both the httpd-devel rpm and the httpd src rpm, and
tried directing --with-apache-src at each directory but no dice.  What
am I doing wrong here?

More information about the CentOS mailing list