[CentOS] Pulling Hair Out - TWiki 4.2 on CentOS 5

Chuck chuck.carson at gmail.com
Wed Jun 18 21:08:12 UTC 2008

Hmmm. That might be correct. I've drilled down into the configure script and
it pukes here:

print STDERR "MARK 10.1\n";
$query = new CGI;  # It dies on this line
print STDERR "MARK 10.2\n";

It never gets to MARK 10.2.

I am using the CPAN version of CGI:

cpan[1]> install CGI
CPAN: Storable loaded ok (v2.15)
Going to write /root/.cpan/Metadata
CGI is up to date (3.37).


Grrr... Frustrating... Each time I've tried to use Twiki over the last few
years we've ran into some show-stopping roadblock. (always been solaris
until now, trying on centos this time)

On Wed, Jun 18, 2008 at 4:00 PM, Les Mikesell <lesmikesell at gmail.com> wrote:

> Chuck wrote:
>> I thought I would turn here before giving up. I am trying to install Twiki
>> 4.2 on CentOS 5 with all updates. (I also tried Twiki 4.1.2 as well)
>> I am running a custom rolled Apache 2.2.8 server and custom rolled PHP
>> 5.2.6 (built with oracle support). These work and are rock solid. I've been
>> using the same config with very heavy duty scripts and php applications with
>> no issues.
>> When trying to run /twiki/bin/configure I get the following error when
>> clicking "Next":
>>  Software error:
>> Use of uninitialized value in substitution (s///) at (eval 25) line 23.
>> The Apache error log says pretty much the same thing. (like 23 by the way
>> points to a commented line; the first 100 or so lines in this script are
>> comments.. If I don't count the commented lines there is no search regexp
>> anywhere near line 23)
>> I then tried version 4.1.2 and the same thing.
>> I googled and found numerous other people having this problem. I have
>> found no responses or solutions. The twiki support site has yielded nothing
>> as well.
>> Just hoping someone here might have sorted this out.. I have set up dozens
>> of twiki sites but haven't played with it in a 2 years or so and
>> wondering... It was never this difficult before.. Three of us have now
>> triple checked every file permissions, installation step, system
>> pre-requisite, etc...
> I have a 4.1.2 version running under Centos 5 without problems but had some
> similar issues trying to upgrade to 4.2, mostly in the configure and module
> installer routines, not normal operation.  I think they have to do with
> mixing CPAN and RPMforge perl modules but I haven't completely pinned it
> down.  Starting fresh, I'd try all EPEL modules for the perl bits missing in
> the stock repo.  I think that will get you to a point where the only
> software error is a 'subroutine install redefined ...' when using the
> configure part to add plugins.
> --
>  Les Mikesell
>   lesmikesell at gmail.com
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Chuck Carson - Sr. Systems Administrator
Northrop Grumman
Austin, Texas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.centos.org/pipermail/centos/attachments/20080618/3363ed99/attachment.htm

More information about the CentOS mailing list